IT技术之家 VMware VMware Avi Load Balancer 32.1.2新功能介绍 – 多云负载均衡平台

    VMware Avi Load Balancer 32.1.2新功能介绍 – 多云负载均衡平台

    VMware Avi Load Balancer(原 NSX Advanced Load Balancer,NSX 高级负载均衡器)是 VMware 多云应用交付平台,采用控制面与数据面分离架构,提供 L4-L7 负载均衡、全局流量调度(GSLB)、Web 应用防火墙与容器 Ingress 服务,支持虚拟机、容器与裸金属部署,具备 API 自动化、弹性扩缩、自愈与应用可视化分析能力,适配混合云与 VCF 环境。32.1.2 是 32.1.x 系列的补丁版本,本文提供其全平台镜像下载。

    ‌VMware Avi Load Balancer‌

    VMware Avi Load Balancer 功能特色

    • 多云负载均衡
      支持全局服务器负载均衡(GSLB)、DNS/IPAM、容器注入服务等功能,可在多云环境中实现应用交付,简化跨云服务部署。
    • Web应用防火墙
      提供Web应用防火墙功能,支持SSL卸载、客户端证书认证等安全服务,保障Web应用安全。
    • 容器Ingress服务
      优化容器化应用部署,支持Kubernetes等容器化环境,提供网络流量管理和安全防护。
    • 弹性扩展与高可用
      采用控制平面与数据平面分离设计,支持Linux服务器云(如OEL 9.5、RHEL 9.5、Ubuntu 22.04),并持续优化性能参数(如引入Intel QuickAssist Technology)。
    • 订阅模式与兼容性
      以服务单元计价,可单独采购,无需捆绑其他VMware产品。32.1.2 修复了 CLI 连接超时、服务引擎无响应、mTLS 握手等多项问题,并一并修复 6 个安全漏洞。

    VMware Avi Load Balancer 32.1.2 更新内容

    发布日期:2026 年 7 月 6 日。本版本以已知问题修复与安全更新为主。

    修复问题

    • AV-252057:与 Avi Load Balancer 控制器的 CLI 连接可能出现超时错误,导致新连接无法访问 Avi CLI。
    • AV-262358:控制器升级到 30.2.6 版本后,部分服务引擎可能变得无响应,导致无法对受影响的服务引擎执行启用、禁用或升级等任何后续操作。
    • AV-267170:当虚拟服务仍存在、而相应云配置的数据网络已被删除时,NSX 云的删除操作可能一直停留在进行中状态。
    • AV-267509:在 Linux Server Cloud 环境中,当控制器部署在基于 VM 的环境中时,服务引擎升级到 32.1.1 版本不生效。
    • AV-267516:升级到 31.2.1 或更高版本并保留先前版本中的部分服务引擎组时,虚拟服务可能进入错误状态。服务引擎上的 VIP 编程仍在进行中,不影响流量。
    • AV-267951:当池服务器在收到完整 POST 请求体之前就提前返回错误响应时,若已禁用 Proxy Expect Header,虚拟服务可能把剩余请求体误当作同一连接上的新请求,从而导致意外的 400 Bad Request 响应。
    • AV-268184:由于 mTLS 握手问题,配置为“请求”或“要求”客户端证书验证的 L7 虚拟服务,可能在客户端证书有效的情况下仍然请求失败。
    • AV-268360:当用户在多个浏览器标签页中同时向启用了 OAuth 的虚拟服务上的应用进行身份验证时,身份验证可能失败并返回 401 Unauthorized 响应。
    • AV-268368:在 Avi Load Balancer 31.2.1 及更高版本中,通过 L7 虚拟服务上传大文件速度缓慢。
    • AV-268492:在增强型虚拟主机(EVH)模式下,应用配置文件的 HTTP 正文大小限制未被强制执行,导致过大的 POST 请求被错误接受(HTTP 200),而非被拒绝(HTTP 413)。
    • AV-268672:在主备(Active-Active)GSLB 环境中,当请求由与会话发起站点不同的站点处理时,OAuth 登录可能失败并返回 401 Unauthorized。
    • AV-269403:在“虚拟服务 > 日志”界面中,除非在虚拟服务设置中启用了非显著性日志记录,否则“非显著日志(Non-significant Logs)”复选框不可勾选,导致无法查看由用户自定义客户端日志过滤器定义的日志。
    • AV-270579:当内容切换规则同时配置了池和特定服务器 IP 时,更新所引用池的默认服务器端口会导致服务器查找失败,使虚拟服务返回 HTTP 500 错误。
    • AV-271218:在界面的拓扑(Topology)视图中,使用连接池组时不会显示虚拟服务的连接池。
    • AV-271477:当 HTTP 响应策略规则针对 Cache-Control 标头时,服务引擎可能因段错误(SIGSEGV)而失败。
    • AV-273284:当虚拟服务配置了应用 Cookie 持久化且 Cookie 值为空时,服务引擎会错误地触发“内存限制已超(Memory limit exceeded)”错误,导致应用请求处理被中断。
    • AV-276855:NSX 云中无效的 Tier-1 和分段(Segment)配置,会导致与有效 Tier-1 对象关联的虚拟服务失败。
    • AV-283255:从 22.1 版本升级到 32.1.x 版本后,控制器管理访问的系统配置更新未反映到 iptables 中。

    安全公告

    • 本版本修复了 CVE-2026-47866、CVE-2026-47867、CVE-2026-47868、CVE-2026-47869、CVE-2026-47870 和 CVE-2026-47871(VMSA-2026-0005)。其中认证绕过漏洞 CVE-2026-47865 仅影响 32.1.1 及更早的版本分支,本版本不受其影响。

    主要变更

    • 移除了“在新服务引擎首次连接控制器时禁用其身份验证”的能力(allow_unauthenticated_nodes 选项)。该选项仅用于不常见的旧版部署模型,不影响当前标准的 Avi Load Balancer 部署模型。自 32.1.2 起,所有新部署的服务引擎都必须使用从控制器获取的有效、未过期且唯一的身份验证令牌进行配置;升级到 32.1.2 前,请确保 allow_unauthenticated_nodes 已设置为 false。
    • 账户锁定策略现已适用于 /api/user-password/* 端点(更新、重置和过期)。反复输入错误的当前密码将导致账户被锁定,以防止未经授权的密码猜测。
    • 通过 File Service 和 File Object API 进行文件上传时,文件名现仅允许使用字母、数字、点、连字符或下划线;包含其他特殊字符的文件名将被阻止上传,必须重命名后才能成功处理。
    • 自 32.1.2 起,支持为 SE_SHM_MEM_HIGH 和 SE_CONN_MEM_HIGH 事件配置阈值。

    32.1.1(2026 年 5 月 12 日发布)是 32.1.x 系列的首个版本,主要增强包括:

    • VCF 9.1 原生集成:成为 VCF 9.1 的即插即用组件,可通过 VCF Operations 自动化部署并全生命周期管理 Avi Controller;通过 VCF Automation 以自助方式提供负载均衡服务,并支持基于租户的配额与隔离。
    • 自动发现与集成:与 vCenter、NSX Manager 直接同步,自动映射网络分段、VPC、项目与计算集群。
    • VKS 支持:AKO(Avi Kubernetes Operator)可在 vSphere Kubernetes Service(VKS)集群上自动部署,提供 L4/L7 负载均衡。
    • Cloud Connector:与 vCenter / NSX Manager 交换敏感数据(如用户凭据)前,先进行 TLS 证书校验。
    • 核心负载均衡:新增 MCP(Model Context Protocol)负载均衡,支持基于 HTTP 的有状态 AI 工作负载,提供会话保持与 OAuth 2.0 授权;NSX 安全组可自动同步为 Avi IP 组。
    • Service Engine:增强网络栈(ENS)性能优化。
    • 许可:全新的安全许可工作流,以数字签名的订阅文件取代 25 位序列号。
    • 界面:基于 VMware Clarity 框架增强“池 > 日志”界面。

    兼容性

    Avi Load Balancer 与 VMware vSphere 互操作性:

    VMware Avi Load Balancer 与 vSphere 互操作性

    升级到 Avi Load Balancer 32.1.x 的要求

    从以下版本支持升级到 Avi Load Balancer 32.1.x:

    【图片占位 2:升级路径表截图,来源:32.1.x Release Notes 的 Checklist for Upgrade to 32.1.x】

    版本系列 升级来源版本 升级到 32.1.1 升级到 32.1.2 升级到 32.1.3
    22.1.x 22.1.4 – 22.1.7 支持 支持 支持
    30.1.x 30.1.1 – 30.1.2 支持 支持 支持
    30.2.x 30.2.1 – 30.2.7 支持 支持 支持
    31.1.x 31.1.1 – 31.1.2 支持 支持 支持
    31.2.x 31.2.1 – 31.2.2 支持 支持 支持
    31.2.x 31.2.3 不支持 不支持 支持
    32.1.x 32.1.1 — 支持 支持
    32.1.x 32.1.2 不支持 — 支持
    • 最低可升级版本为 22.1.4,跨多个大版本升级时需按升级路径逐级进行。
    • 升级到 32.1.2 前,确保系统配置 allow_unauthenticated_nodes 已设置为 false,否则升级将被阻止。
    • 自 31.1.1 起,Avi Load Balancer 要求 VMware vCenter 与 ESXi 7.0 或更高版本,升级前请先将环境升级到位。
    • 升级前请确认控制器已应用有效许可证;仅使用内置评估(Eval/Trial)许可证时,升级会被阻止。

    相关文件下载

    VMware Avi Load Balancer 32.1.2下载

    文件列表:

    Item File Name Size
    CLI Packages – Standalone CLI Shell avi_shell-32.1.2-9077.tar.gz 2.00 MB
    VMWARE – Controller OVA controller-32.1.2-9077.ova 3.83 GB
    Upgrade – VMware / OpenStack / AWS / KVM / CSP controller-32.1.2-9077.pkg 3.58 GB
    OpenStack / KVM / CSP – Controller Qcow2 controller-32.1.2-9077.qcow2 3.78 GB
    OpenStack / KVM / CSP – Controller Raw Image controller-32.1.2-9077.raw.gz 3.54 GB
    Microsoft Azure – Controller VHD controller-32.1.2-9077.vhd 11.00 GB
    Upgrade – Container Clouds / Linux Server controller_docker-32.1.2-9077.tgz 4.47 GB
    Linux Server Cloud (Bare Metal) – Docker Install Image docker_install-32.1.2-9077.tar.gz 5.58 GB
    Controller GCP gcp_controller-32.1.2-9077.tar.gz 3.54 GB
    开源组件许可声明(Open Source Licenses) Avi_Load_Balancer_open_source_licenses_32_1_2.txt 2.32 MB
    控制器首次登录的默认管理员账号密码(首次登录后请立即修改) Default_password.txt 15 B
    License Hub OVA,VMware vDefend 与 Avi Load Balancer 的集中许可证管理平台 License-Hub-2.0.0.0.0.25630952.ova 11.04 GB
    License Hub – VMware vDefend 与 Avi Load Balancer Notices 文件 License_Hub_for_VMware_vDefend_and_VMware_Avi_Load_Balancers-Notices_File.txt 6.37 MB
    • 文件完整(约50G)
    • 百度网盘链接:

    更多:

    VMware Avi Load Balancer 31.2.3镜像下载

    VMware Avi Load Balancer 30.2.4镜像下载

    VMware NSX 4.2.3 – 网络安全虚拟化平台

    1、本站提供的软件均为 “试用版” 或者 “免费版”,仅供学习和研究使用
    2、友情提醒:内容全部搜集自网络,安装教程参照压缩包内的Readme.txt编写
    3、因使用本站软件产生的法律责任由使用者自行承担,本站不承担任何连带责任。
    4、如有内容不慎侵犯了您的权益,请速与我联系!
    如有转载请注明出处:https://www.ittel.cn/archives/71098.html
    guest
    0 评论
    内联反馈
    查看所有评论
    联系我们

    联系我们

    QQ:877196754

    在线咨询: QQ交谈

    邮箱: ittel@qq.com

    工作时间:周一至周日,8:00-21:00
    返回顶部
    0
    希望看到您的想法,请您发表评论x